re = /\d{1,2}\.\d{1,2}\.\d{4}(?:\s+\d{1,2}:\d{1,2})?/m
str = 'Hospitalization from 25.1.2018 to 26.1.2018
Date of hospitalization was from 28.8.2019 8:15
Date of arrival 30.6.2018 20:30 to hospital'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end