using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"username"": ""(?<username>[^""\\]*(?:\\""[^""]*)*)""";
string input = @"...""members"": [{""id"": ""0"", ""username"": ""User 1"", ""discriminator"": ""0000"", ""avatar"": null, ""status"": ""online"", ""deaf"": false, ""mute"": false, ""self_deaf"": false, ""self_mute"": false, ""suppress"": false, ""channel_id"": ""0123456789"", ""avatar_url"": ""https://...""}, {""id"": ""1"", ""username"": ""User 2"", ""discriminator"": ""0000"", ""avatar"": null, ""status"": ""online"", ""game"": {""name"": ""pls help""}, ""avatar_url"": ""https://...""}, {""id"": ""2"", ""username"": ""Bot 1"", ""discriminator"": ""0000"", ""avatar"": null, ""status"": ""online"", ""game"": {""name"": ""music | ;;help""}, ""deaf"": false, ""mute"": false, ""self_deaf"": false, ""self_mute"": false, ""suppress"": false, ""channel_id"": ""1234567890"", ""avatar_url"": ""https://...""}, {""id"": ""3"", ""username"": ""Use\""r 3"", ""discriminator"": ""0000"", ""avatar"": null, ""status"": ""online"", ""deaf"": false, ""mute"": false, ""self_deaf"": false, ""self_mute"": false, ""suppress"": false, ""channel_id"": ""2345678901"", ""avatar_url"": ""https://...""}], ""presence_count"": 4}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}