import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "username\": \"(?<username>[^\"\\\\]*(?:\\\\\"[^\"]*)*)\"";
final String string = "...\"members\": [{\"id\": \"0\", \"username\": \"User 1\", \"discriminator\": \"0000\", \"avatar\": null, \"status\": \"online\", \"deaf\": false, \"mute\": false, \"self_deaf\": false, \"self_mute\": false, \"suppress\": false, \"channel_id\": \"0123456789\", \"avatar_url\": \"https://...\"}, {\"id\": \"1\", \"username\": \"User 2\", \"discriminator\": \"0000\", \"avatar\": null, \"status\": \"online\", \"game\": {\"name\": \"pls help\"}, \"avatar_url\": \"https://...\"}, {\"id\": \"2\", \"username\": \"Bot 1\", \"discriminator\": \"0000\", \"avatar\": null, \"status\": \"online\", \"game\": {\"name\": \"music | ;;help\"}, \"deaf\": false, \"mute\": false, \"self_deaf\": false, \"self_mute\": false, \"suppress\": false, \"channel_id\": \"1234567890\", \"avatar_url\": \"https://...\"}, {\"id\": \"3\", \"username\": \"Use\\\"r 3\", \"discriminator\": \"0000\", \"avatar\": null, \"status\": \"online\", \"deaf\": false, \"mute\": false, \"self_deaf\": false, \"self_mute\": false, \"suppress\": false, \"channel_id\": \"2345678901\", \"avatar_url\": \"https://...\"}], \"presence_count\": 4}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}