import re
regex = re.compile(r"username\": \"(?<username>[^\"\\]*(?:\\\"[^\"]*)*)\"", flags=re.MULTILINE)
test_str = "...\"members\": [{\"id\": \"0\", \"username\": \"User 1\", \"discriminator\": \"0000\", \"avatar\": null, \"status\": \"online\", \"deaf\": false, \"mute\": false, \"self_deaf\": false, \"self_mute\": false, \"suppress\": false, \"channel_id\": \"0123456789\", \"avatar_url\": \"https://...\"}, {\"id\": \"1\", \"username\": \"User 2\", \"discriminator\": \"0000\", \"avatar\": null, \"status\": \"online\", \"game\": {\"name\": \"pls help\"}, \"avatar_url\": \"https://...\"}, {\"id\": \"2\", \"username\": \"Bot 1\", \"discriminator\": \"0000\", \"avatar\": null, \"status\": \"online\", \"game\": {\"name\": \"music | ;;help\"}, \"deaf\": false, \"mute\": false, \"self_deaf\": false, \"self_mute\": false, \"suppress\": false, \"channel_id\": \"1234567890\", \"avatar_url\": \"https://...\"}, {\"id\": \"3\", \"username\": \"Use\\\"r 3\", \"discriminator\": \"0000\", \"avatar\": null, \"status\": \"online\", \"deaf\": false, \"mute\": false, \"self_deaf\": false, \"self_mute\": false, \"suppress\": false, \"channel_id\": \"2345678901\", \"avatar_url\": \"https://...\"}], \"presence_count\": 4}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")