// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)username": "(?<username>[^"\\]*(?:\\"[^"]*)*)""#).unwrap();
let string = "...\"members\": [{\"id\": \"0\", \"username\": \"User 1\", \"discriminator\": \"0000\", \"avatar\": null, \"status\": \"online\", \"deaf\": false, \"mute\": false, \"self_deaf\": false, \"self_mute\": false, \"suppress\": false, \"channel_id\": \"0123456789\", \"avatar_url\": \"https://...\"}, {\"id\": \"1\", \"username\": \"User 2\", \"discriminator\": \"0000\", \"avatar\": null, \"status\": \"online\", \"game\": {\"name\": \"pls help\"}, \"avatar_url\": \"https://...\"}, {\"id\": \"2\", \"username\": \"Bot 1\", \"discriminator\": \"0000\", \"avatar\": null, \"status\": \"online\", \"game\": {\"name\": \"music | ;;help\"}, \"deaf\": false, \"mute\": false, \"self_deaf\": false, \"self_mute\": false, \"suppress\": false, \"channel_id\": \"1234567890\", \"avatar_url\": \"https://...\"}, {\"id\": \"3\", \"username\": \"Use\\\"r 3\", \"discriminator\": \"0000\", \"avatar\": null, \"status\": \"online\", \"deaf\": false, \"mute\": false, \"self_deaf\": false, \"self_mute\": false, \"suppress\": false, \"channel_id\": \"2345678901\", \"avatar_url\": \"https://...\"}], \"presence_count\": 4}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}