using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<!gf_)apply_filters|do_action).*?\( ?('|"")(.*?)('|"").*";
string input = @"apply_filters( 'gform_export_separator', ',', $form_id );
do_action( 'gform_export_separator', ',', $form_id );";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}