const regex = /((?<!gf_)apply_filters|do_action).*?\( ?('|")(.*?)('|").*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<!gf_)apply_filters|do_action).*?\\( ?(\'|")(.*?)(\'|").*', 'gm')
const str = `apply_filters( 'gform_export_separator', ',', \$form_id );
do_action( 'gform_export_separator', ',', \$form_id );`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}