#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(\/\/[ \t\u00a0\u1680\u2000-\u200a\u2028\u2029\u202f\u205f\u3000\ufeff]*(@ts-(no)?check)($|\n|\r\n))"
Local $sString = " // @ts-check" & @CRLF & _
"// ts-check" & @CRLF & _
"" & @CRLF & _
" // @ts-nocheck" & @CRLF & _
"// @ts-check " & @CRLF & _
"// @ts-nocheck " & @CRLF & _
"" & @CRLF & _
"// @ts-check " & @CRLF & _
"" & @CRLF & _
"// @ts-check " & @CRLF & _
"/** @ts-check */" & @CRLF & _
"/* @ts-check */" & @CRLF & _
"// @ts-check"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")