import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(\\/\\/[ \\t\\u00a0\\u1680\\u2000-\\u200a\\u2028\\u2029\\u202f\\u205f\\u3000\\ufeff]*(@ts-(no)?check)($|\\n|\\r\\n))";
final String string = " // @ts-check\n"
+ "// ts-check\n\n"
+ " // @ts-nocheck\n"
+ "// @ts-check \n"
+ "// @ts-nocheck \n\n"
+ "// @ts-check \n\n"
+ "// @ts-check \n"
+ "/** @ts-check */\n"
+ "/* @ts-check */\n"
+ "// @ts-check";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}