package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(\/\/[ \t\u00a0\u1680\u2000-\u200a\u2028\u2029\u202f\u205f\u3000\ufeff]*(@ts-(no)?check)($|\n|\r\n))`)
var str = ` // @ts-check
// ts-check
// @ts-nocheck
// @ts-check
// @ts-nocheck
// @ts-check
// @ts-check
/** @ts-check */
/* @ts-check */
// @ts-check`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}