// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*(\/\/[ \t\u00a0\u1680\u2000-\u200a\u2028\u2029\u202f\u205f\u3000\ufeff]*(@ts-(no)?check)($|\n|\r\n))").unwrap();
let string = " // @ts-check
// ts-check
// @ts-nocheck
// @ts-check
// @ts-nocheck
// @ts-check
// @ts-check
/** @ts-check */
/* @ts-check */
// @ts-check";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}