using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^s3:\/\/[a-z0-9-]+(\/[^/]+)*\/[^/]+\.sar$";
string input = @"s3://asf-frostbyte/slimsar/SAR_11072025_110035.sar
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}