// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^s3:\/\/[a-z0-9-]+(\/[^/]+)*\/[^/]+\.sar$").unwrap();
let string = "s3://asf-frostbyte/slimsar/SAR_11072025_110035.sar
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}