$re = '/^s3:\/\/[a-z0-9-]+(\/[^/]+)*\/[^/]+\.sar$/m';
$str = 's3://asf-frostbyte/slimsar/SAR_11072025_110035.sar
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);