package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^s3:\/\/[a-z0-9-]+(\/[^/]+)*\/[^/]+\.sar$`)
var str = `s3://asf-frostbyte/slimsar/SAR_11072025_110035.sar
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}