#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^@[^{]+\{([^,]+),"
Local $sString = "@Article{m2023a," & @CRLF & _
" author = {S. Macdonald}," & @CRLF & _
" journal = {Social Science Information}," & @CRLF & _
" title = {The gaming of citation and authorship in academic journals: a warning from medicine}," & @CRLF & _
" year = {2023}," & @CRLF & _
" doi = {10.1177/05390184221142218}," & @CRLF & _
" issue = {In Press}," & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"@Misc{b2017a," & @CRLF & _
" author = {S. Buranyi}," & @CRLF & _
" title = {Is the staggeringly profitable business of scientific publishing bad for science?}," & @CRLF & _
" year = {2017}," & @CRLF & _
" journal = {The Guardian, 27 June 2017}," & @CRLF & _
" url = {https://www.theguardian.com/science/2017/jun/27/profitable-business-scientific-publishing-bad-for-science}," & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")