import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^@[^\\{]+\\{([^,]+),";
final String string = "@Article{m2023a,\n"
+ " author = {S. Macdonald},\n"
+ " journal = {Social Science Information},\n"
+ " title = {The gaming of citation and authorship in academic journals: a warning from medicine},\n"
+ " year = {2023},\n"
+ " doi = {10.1177/05390184221142218},\n"
+ " issue = {In Press},\n"
+ "}\n\n"
+ "@Misc{b2017a,\n"
+ " author = {S. Buranyi},\n"
+ " title = {Is the staggeringly profitable business of scientific publishing bad for science?},\n"
+ " year = {2017},\n"
+ " journal = {The Guardian, 27 June 2017},\n"
+ " url = {https://www.theguardian.com/science/2017/jun/27/profitable-business-scientific-publishing-bad-for-science},\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}