using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![\[{,:\]}]+[\[{,:\]}\s]*)""(?!\s*[\[{,:\]}])";
string substitution = @"\\$&";
string input = @"{
""Equipment Contents"": [
""XL APPEARANCE GROUP"",
""body-color grille"",
""body-color body-side molding with chrome insert"",
""luggage rack"",
""15"" deep-dish cast aluminum wheels"",
""P235/75R15SL all-terrain OWL tires"",
""power door locks"",
""power windows"",
""power mirrors"",
""cloth captains chairs""
]
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}