const regex = /(?<![\[{,:\]}]+[\[{,:\]}\s]*)"(?!\s*[\[{,:\]}])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![\\[{,:\\]}]+[\\[{,:\\]}\\s]*)"(?!\\s*[\\[{,:\\]}])', 'gm')
const str = `{
"Equipment Contents": [
"XL APPEARANCE GROUP",
"body-color grille",
"body-color body-side molding with chrome insert",
"luggage rack",
"15" deep-dish cast aluminum wheels",
"P235/75R15SL all-terrain OWL tires",
"power door locks",
"power windows",
"power mirrors",
"cloth captains chairs"
]
}`;
const subst = `\\$&`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);