import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\[\\{,:\\]\\}]+[\\[\\{,:\\]\\}\\s]*)\"(?!\\s*[\\[\\{,:\\]\\}])";
final String string = "{\n"
+ " \"Equipment Contents\": [\n"
+ " \"XL APPEARANCE GROUP\",\n"
+ " \"body-color grille\",\n"
+ " \"body-color body-side molding with chrome insert\",\n"
+ " \"luggage rack\",\n"
+ " \"15\" deep-dish cast aluminum wheels\",\n"
+ " \"P235/75R15SL all-terrain OWL tires\",\n"
+ " \"power door locks\",\n"
+ " \"power windows\",\n"
+ " \"power mirrors\",\n"
+ " \"cloth captains chairs\"\n"
+ " ]\n"
+ "}";
final String subst = "\\\\$&";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}