# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=Name-)\d*(\d{3})/$1/gm;t' <<< "\"Name-0000425\"
\"Name-00123\"
\"Name-123\""