re = /(?<=Name-)\d*(\d{3})/m
str = '"Name-0000425"
"Name-00123"
"Name-123"'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result