$re = '/(?<=Name-)\d*(\d{3})/m';
$str = '"Name-0000425"
"Name-00123"
"Name-123"';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;