use strict;
my $str = '"Name-0000425"
"Name-00123"
"Name-123"';
my $regex = qr/(?<=Name-)\d*(\d{3})/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";