using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!(東京|大阪))(?<!(北海道|神奈川))特許事務所";
string input = @"東京特許事務所
大阪特許事務所
北海道特許事務所
神奈川特許事務所
群馬特許事務所";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}