const regex = /(?<!(東京|大阪))(?<!(北海道|神奈川))特許事務所/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!(東京|大阪))(?<!(北海道|神奈川))特許事務所', 'gm')
const str = `東京特許事務所
大阪特許事務所
北海道特許事務所
神奈川特許事務所
群馬特許事務所`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}