import re
regex = re.compile(r"(?<!(東京|大阪))(?<!(北海道|神奈川))特許事務所", flags=re.MULTILINE)
test_str = ("東京特許事務所\n"
"大阪特許事務所\n"
"北海道特許事務所\n"
"神奈川特許事務所\n"
"群馬特許事務所")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")