const regex = /(<\s?a\s?href="https?:\/\/([\da-z\.-]+\.[a-z\.]{2,6})\/(@[\/\w._-]*)"\s?.*<\s?\/\s?a\s?>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\s?a\\s?href="https?:\\\/\\\/([\\da-z\\.-]+\\.[a-z\\.]{2,6})\\\/(@[\\\/\\w._-]*)"\\s?.*<\\s?\\\/\\s?a\\s?>)', 'g')
const str = `caught once when a space between URLs :(
<a href="https://mastodon.social/@tom79" class="u-url mention">@<span>tom79</span></a> <a href="https://mastodon.social/@mastalab" class="u-url mention">@<span>Mastalab</span></a>
caught separately when no space between URLs :)
<a href="https://mastodon.social/@tom79" class="u-url mention">@<span>tom79</span></a>
<a href="https://mastodon.social/@mastalab" class="u-url mention">@<span>Mastalab</span></a>
How to change this regex to make the first case work???`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}