// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<\s?a\s?href="https?:\/\/([\da-z\.-]+\.[a-z\.]{2,6})\/(@[\/\w._-]*)"\s?.*<\s?\/\s?a\s?>)"#).unwrap();
let string = "caught once when a space between URLs :(
<a href=\"https://mastodon.social/@tom79\" class=\"u-url mention\">@<span>tom79</span></a> <a href=\"https://mastodon.social/@mastalab\" class=\"u-url mention\">@<span>Mastalab</span></a>
caught separately when no space between URLs :)
<a href=\"https://mastodon.social/@tom79\" class=\"u-url mention\">@<span>tom79</span></a>
<a href=\"https://mastodon.social/@mastalab\" class=\"u-url mention\">@<span>Mastalab</span></a>
How to change this regex to make the first case work???";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}