$re = '/(<\s?a\s?href="https?:\/\/([\da-z\.-]+\.[a-z\.]{2,6})\/(@[\/\w._-]*)"\s?.*<\s?\/\s?a\s?>)/';
$str = 'caught once when a space between URLs :(
<a href="https://mastodon.social/@tom79" class="u-url mention">@<span>tom79</span></a> <a href="https://mastodon.social/@mastalab" class="u-url mention">@<span>Mastalab</span></a>
caught separately when no space between URLs :)
<a href="https://mastodon.social/@tom79" class="u-url mention">@<span>tom79</span></a>
<a href="https://mastodon.social/@mastalab" class="u-url mention">@<span>Mastalab</span></a>
How to change this regex to make the first case work???';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);