import Foundation
let pattern = #"(<\s?a\s?href="https?:\/\/([\da-z\.-]+\.[a-z\.]{2,6})\/(@[\/\w._-]*)"\s?.*<\s?\/\s?a\s?>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
caught once when a space between URLs :(
<a href="https://mastodon.social/@tom79" class="u-url mention">@<span>tom79</span></a> <a href="https://mastodon.social/@mastalab" class="u-url mention">@<span>Mastalab</span></a>
caught separately when no space between URLs :)
<a href="https://mastodon.social/@tom79" class="u-url mention">@<span>tom79</span></a>
<a href="https://mastodon.social/@mastalab" class="u-url mention">@<span>Mastalab</span></a>
How to change this regex to make the first case work???
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)