package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-9]\d*(?:[-\s]?[a-zA-Z0-9]+)?$`)
var str = `25
25 a
25b
25-ab
12-14
0
b
0a
00a
a a
00 a
13àâäèéêë`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}