// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1-9]\d*(?:[-\s]?[a-zA-Z0-9]+)?$").unwrap();
let string = "25
25 a
25b
25-ab
12-14
0
b
0a
00a
a a
00 a
13àâäèéêë";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}