import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1-9]\\d*(?:[-\\s]?[a-zA-Z0-9]+)?$";
final String string = "25\n"
+ "25 a\n"
+ "25b\n"
+ "25-ab\n"
+ "12-14\n"
+ "0\n"
+ "b\n"
+ "0a\n"
+ "00a\n"
+ "a a\n"
+ "00 a\n"
+ "13àâäèéêë";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}