re = /^[1-9]\d*(?:[-\s]?[a-zA-Z0-9]+)?$/m
str = '25
25 a
25b
25-ab
12-14
0
b
0a
00a
a a
00 a
13àâäèéêë'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end