#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?:\/\/(www\.)?[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}(\?s=|\/)[a-zA-Z0-9()-.?_=&;#\/]{1,256}"
Local $sString = "'http://www.stocktargetadvisor.com/toprating'" & @CRLF & _
"'https://dividendbot.com?s=BA'" & @CRLF & _
"'http://sunshineavenue.com/stock/SNPS/'" & @CRLF & _
"'https://dividendbot.com?s=PFE', " & @CRLF & _
"'http://sunshineavenue.com/stock/SNPS/ via @sunshineave', " & @CRLF & _
"'https://dividendbot.com?s=AAPL', 'http://www.stocktargetadvisor.com/toprating'," & @CRLF & _
"'https://www.chartmill.com/analyze.php?utm_source=stocktwits&utm_medium=FA&utm_content=HEALTH&utm_campaign=social_tracking#/NKE?r=fa&key=8832fee1-d06b-46b5-827f-26246a5e29a8'" & @CRLF & _
"'https://www.seeitmarket.com/2-bullish-stocks-twitter-twtr-and-michael-kors-18140/," & @CRLF & _
"'https://www.chartmill.com/analyze.php?utm_source=stocktwits&utm_medium=FA&utm_content=HEALTH&utm_campaign=social_tracking#/FSLR?r=fa&key=b431cf47-ec7e-4226-b864-511b6081b3be'" & @CRLF & _
"'https://dividendbot.com?s=CVS'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")