import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/(www\\.)?[-a-zA-Z0-9@:%._\\+~#=]{1,256}\\.[a-zA-Z0-9()]{1,6}(\\?s=|\\/)[a-zA-Z0-9()-.?_=&;#\\/]{1,256}";
final String string = "'http://www.stocktargetadvisor.com/toprating'\n"
+ "'https://dividendbot.com?s=BA'\n"
+ "'http://sunshineavenue.com/stock/SNPS/'\n"
+ "'https://dividendbot.com?s=PFE', \n"
+ "'http://sunshineavenue.com/stock/SNPS/ via @sunshineave', \n"
+ "'https://dividendbot.com?s=AAPL', 'http://www.stocktargetadvisor.com/toprating',\n"
+ "'https://www.chartmill.com/analyze.php?utm_source=stocktwits&utm_medium=FA&utm_content=HEALTH&utm_campaign=social_tracking#/NKE?r=fa&key=8832fee1-d06b-46b5-827f-26246a5e29a8'\n"
+ "'https://www.seeitmarket.com/2-bullish-stocks-twitter-twtr-and-michael-kors-18140/,\n"
+ "'https://www.chartmill.com/analyze.php?utm_source=stocktwits&utm_medium=FA&utm_content=HEALTH&utm_campaign=social_tracking#/FSLR?r=fa&key=b431cf47-ec7e-4226-b864-511b6081b3be'\n"
+ "'https://dividendbot.com?s=CVS'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}