import re
regex = re.compile(r"https?:\/\/(www\.)?[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}(\?s=|\/)[a-zA-Z0-9()-.?_=&;#\/]{1,256}", flags=re.MULTILINE)
test_str = ("'http://www.stocktargetadvisor.com/toprating'\n"
"'https://dividendbot.com?s=BA'\n"
"'http://sunshineavenue.com/stock/SNPS/'\n"
"'https://dividendbot.com?s=PFE', \n"
"'http://sunshineavenue.com/stock/SNPS/ via @sunshineave', \n"
"'https://dividendbot.com?s=AAPL', 'http://www.stocktargetadvisor.com/toprating',\n"
"'https://www.chartmill.com/analyze.php?utm_source=stocktwits&utm_medium=FA&utm_content=HEALTH&utm_campaign=social_tracking#/NKE?r=fa&key=8832fee1-d06b-46b5-827f-26246a5e29a8'\n"
"'https://www.seeitmarket.com/2-bullish-stocks-twitter-twtr-and-michael-kors-18140/,\n"
"'https://www.chartmill.com/analyze.php?utm_source=stocktwits&utm_medium=FA&utm_content=HEALTH&utm_campaign=social_tracking#/FSLR?r=fa&key=b431cf47-ec7e-4226-b864-511b6081b3be'\n"
"'https://dividendbot.com?s=CVS'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")