using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/(www\.)?[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}(\?s=|\/)[a-zA-Z0-9()-.?_=&;#\/]{1,256}";
string input = @"'http://www.stocktargetadvisor.com/toprating'
'https://dividendbot.com?s=BA'
'http://sunshineavenue.com/stock/SNPS/'
'https://dividendbot.com?s=PFE',
'http://sunshineavenue.com/stock/SNPS/ via @sunshineave',
'https://dividendbot.com?s=AAPL', 'http://www.stocktargetadvisor.com/toprating',
'https://www.chartmill.com/analyze.php?utm_source=stocktwits&utm_medium=FA&utm_content=HEALTH&utm_campaign=social_tracking#/NKE?r=fa&key=8832fee1-d06b-46b5-827f-26246a5e29a8'
'https://www.seeitmarket.com/2-bullish-stocks-twitter-twtr-and-michael-kors-18140/,
'https://www.chartmill.com/analyze.php?utm_source=stocktwits&utm_medium=FA&utm_content=HEALTH&utm_campaign=social_tracking#/FSLR?r=fa&key=b431cf47-ec7e-4226-b864-511b6081b3be'
'https://dividendbot.com?s=CVS'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}