$re = '/”([^”]*?Voldemort.*?”|.*?”(*SKIP)(*FAIL))/mi';
$str = '”voldemort is angy” said Voldemort. ”no voldi” ”again” voldemort ” Voldemort” Voldemort ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);