re = /”([^”]*?Voldemort.*?”|.*?”(*SKIP)(*FAIL))/mi
str = '”voldemort is angy” said Voldemort. ”no voldi” ”again” voldemort ” Voldemort” Voldemort '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end