#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\p{Zs}*(<(?:/?[xg]\d|[xg]\d/)>\p{Zs}*)+\p{Zs}*$"
Local $sString = "<x1/>" & @CRLF & _
"<x1/><x2/>" & @CRLF & _
"<g1></g1>" & @CRLF & _
"" & @CRLF & _
"<x1/><g1></g1>" & @CRLF & _
"<x1/><x1/><x2/>" & @CRLF & _
"" & @CRLF & _
" <x1/>" & @CRLF & _
" <x1/><x2/>" & @CRLF & _
" <g1></g1>" & @CRLF & _
"" & @CRLF & _
" <x1/><g1></g1>" & @CRLF & _
" <x1/><x1/><x2/>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<x1/> " & @CRLF & _
"<x1/><x2/> " & @CRLF & _
" <g1></g1> " & @CRLF & _
"<g1> </g1>" & @CRLF & _
" <g1> </g1>" & @CRLF & _
"<g1> </g1> " & @CRLF & _
"" & @CRLF & _
" <x1/><x1/><x2/>" & @CRLF & _
" <x1/> <x1/><x2/>" & @CRLF & _
" <x1/><x1/> <x2/>" & @CRLF & _
" <x1/><x1/> <x2/> " & @CRLF & _
" <x1/> <x1/> <x2/>" & @CRLF & _
" <x1/> <x1/> <x2/> " & @CRLF & _
"<x1/> <x1/> <x2/>" & @CRLF & _
"<x1/> <x1/> <x2/> " & @CRLF & _
"<x1/><x1/> <x2/>" & @CRLF & _
"<x1/><x1/> <x2/> " & @CRLF & _
"" & @CRLF & _
" <x1/>" & @CRLF & _
" <x1/><x2/>" & @CRLF & _
" <g1></g1>" & @CRLF & _
"" & @CRLF & _
" <x1/><g1></g1>" & @CRLF & _
" <x1/><x1/><x2/>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<x1/> " & @CRLF & _
"<x1/><x2/> " & @CRLF & _
" <g1></g1> " & @CRLF & _
"<g1> </g1>" & @CRLF & _
" <g1> </g1>" & @CRLF & _
"<g1> </g1> " & @CRLF & _
"" & @CRLF & _
" <x1/><x1/><x2/>" & @CRLF & _
" <x1/> <x1/><x2/>" & @CRLF & _
" <x1/><x1/> <x2/>" & @CRLF & _
" <x1/><x1/> <x2/> " & @CRLF & _
" <x1/> <x1/> <x2/>" & @CRLF & _
" <x1/> <x1/> <x2/> " & @CRLF & _
"<x1/> <x1/> <x2/>" & @CRLF & _
"<x1/> <x1/> <x2/> " & @CRLF & _
"<x1/><x1/> <x2/>" & @CRLF & _
"<x1/><x1/> <x2/> " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")