// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\p{Zs}*(<(?:/?[xg]\d|[xg]\d/)>\p{Zs}*)+\p{Zs}*$").unwrap();
let string = "<x1/>
<x1/><x2/>
<g1></g1>
<x1/><g1></g1>
<x1/><x1/><x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<x1/><g1></g1>
<x1/><x1/><x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<g1> </g1>
<g1> </g1>
<g1> </g1>
<x1/><x1/><x2/>
<x1/> <x1/><x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<x1/><g1></g1>
<x1/><x1/><x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<g1> </g1>
<g1> </g1>
<g1> </g1>
<x1/><x1/><x2/>
<x1/> <x1/><x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}