re = /^\p{Zs}*(<(?:\/?[xg]\d|[xg]\d\/)>\p{Zs}*)+\p{Zs}*$/m
str = '<x1/>
<x1/><x2/>
<g1></g1>
<x1/><g1></g1>
<x1/><x1/><x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<x1/><g1></g1>
<x1/><x1/><x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<g1> </g1>
<g1> </g1>
<g1> </g1>
<x1/><x1/><x2/>
<x1/> <x1/><x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<x1/><g1></g1>
<x1/><x1/><x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<g1> </g1>
<g1> </g1>
<g1> </g1>
<x1/><x1/><x2/>
<x1/> <x1/><x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end