import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bItem\\s+5\\.02\\s*([\\w\\W]*?)(?=\\s*(?:Item\\s+(?:[89]\\.01|5\\.0[37])|SIGNATURES?|Pursuant\\s+to\\s+the\\s+requirements\\s+of\\s+the\\s+Securities\\s+Exchange\\s+Act\\s+of\\s+1934)\\b)";
final String string = "Item 5.02 text\n"
+ "text\n"
+ "text\n"
+ " Item 8.01\n"
+ "Item 5.02 text\n"
+ "text\n"
+ " Item 9.01\n"
+ "Item 5.02 text\n"
+ "text\n"
+ " Item 5.03\n"
+ "Item 5.02 text\n"
+ "text\n"
+ " Item 5.07\n"
+ "Item 5.02 text\n"
+ "text\n"
+ " SIGNATURES\n"
+ "Item 5.02 text\n"
+ "text\n"
+ " SIGNATURE\n"
+ "Item 5.02 text\n"
+ "text\n"
+ " Pursuant to the requirements of\n"
+ " the Securities Exchange Act of 1934";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}