$re = '/\bItem\s+5\.02\s*([\w\W]*?)(?=\s*(?:Item\s+(?:[89]\.01|5\.0[37])|SIGNATURES?|Pursuant\s+to\s+the\s+requirements\s+of\s+the\s+Securities\s+Exchange\s+Act\s+of\s+1934)\b)/m';
$str = 'Item 5.02 text
text
text
Item 8.01
Item 5.02 text
text
Item 9.01
Item 5.02 text
text
Item 5.03
Item 5.02 text
text
Item 5.07
Item 5.02 text
text
SIGNATURES
Item 5.02 text
text
SIGNATURE
Item 5.02 text
text
Pursuant to the requirements of
the Securities Exchange Act of 1934';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);