use strict;
my $str = 'Item 5.02 text
text
text
Item 8.01
Item 5.02 text
text
Item 9.01
Item 5.02 text
text
Item 5.03
Item 5.02 text
text
Item 5.07
Item 5.02 text
text
SIGNATURES
Item 5.02 text
text
SIGNATURE
Item 5.02 text
text
Pursuant to the requirements of
the Securities Exchange Act of 1934';
my $regex = qr/\bItem\s+5\.02\s*([\w\W]*?)(?=\s*(?:Item\s+(?:[89]\.01|5\.0[37])|SIGNATURES?|Pursuant\s+to\s+the\s+requirements\s+of\s+the\s+Securities\s+Exchange\s+Act\s+of\s+1934)\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}