using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\< *[img][^\\\\>]*[src] *= *[\\""\\']{0,1}([^\\""\\'\\ >]*)";
string input = @"<img src=""//cdn2.jianshu.io/assets/web/logo-58fd04f6f0de908401aa561cda6a0688.png"" alt=""Logo"">";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}