$re = '/\< *[img][^\\\\\\\\>]*[src] *= *[\\\\"\\\\\']{0,1}([^\\\\"\\\\\'\\\\ >]*)/';
$str = '<img src="//cdn2.jianshu.io/assets/web/logo-58fd04f6f0de908401aa561cda6a0688.png" alt="Logo">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);