const regex = /\< *[img][^\\\\>]*[src] *= *[\\"\\']{0,1}([^\\"\\'\\ >]*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\< *[img][^\\\\\\\\>]*[src] *= *[\\\\"\\\\\']{0,1}([^\\\\"\\\\\'\\\\ >]*)', '')
const str = `<img src="//cdn2.jianshu.io/assets/web/logo-58fd04f6f0de908401aa561cda6a0688.png" alt="Logo">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}